Monatsarchiv für Juli 2019

Die Steuer …

Martina am 30. Juli 2019

… und ich. Wir haben ein etwas gespanntes Verhältnis, was den Zeitrahmen angeht.
Diesem ist es jedenfalls zu verdanken, dass ich jedes Jahr die Steuererklärung auf den allerallerletzten Drücker abgebe. So auch dieses Jahr. Bis morgen darf man, heute habe ich.
Immerhin einen Tag vor der Deadline. 😉
Gottseidank muss man neuerdingens keine Belege mehr abgeben (nur noch auf Aufforderung, glaube ich), manche Vertragspartner schicken die Steuerbescheinigungen sogar gleich ans Finanzamt – wobei ich mir noch nicht sicher bin, ob ich das gut oder schlecht finde -, ausserdem geht dank Elster alles seinen elektronischen Weg.

Nun sitze ich hier, und fühle mich wie nach einer lange vorbereiteten Prüfung, drüben lauert schon das Loch, in dem die in den letzten Tagen aufgebrachte Energie zur erfolgreichen Prokrastination verschwinden möchte.
Mit anderen Worten: was mache ich denn jetzt?

Abgelegt unter Büro | Keine Kommentare

Gutenberg

Martina am 21. Juli 2019

Okay, jetzt ist es also soweit. Ich wollte eigentlich nur ein Plugin updaten, habe aber auf den falschen Knopf gedrückt, und ehe ich mich versah, war Gutenberg da.

Gottseidank ist das Theme wohl kompatibel, am Aussehen hat sich jedenfalls auf den ersten Blick nichts geändert.

Muss nur noch nachsehen, ob auch alle Plugins weiter funktionieren.
Tja, so schnell kann man ein (ungeliebtes) Update machen.

Abgelegt unter Allgemein | Keine Kommentare

Visual Studio und Unreal Engine

Martina am 17. Juli 2019

Puh, nach einer geschlagenen Woche habe ich es endlich geschafft, Unreal Engine dazu zu bringen, eine C++-Klasse ohne Fehler zu compilen.

Das klappte früher ohne Probleme, zwischenzeitlich hatte ich aber UE länger nicht angeworfen, nun wollte ich endlich mal den ein oder anderen Kurs vollenden, da war es ein zähes Ringen.
Das Log-File und Google halfen leider nur teilweise, für viele Fehlermeldungen gab es auch im UE Hub keine (für mich) befriedigende Lösung.

Wie ich das letztendlich doch geschafft habe, kann ich nach den vielen Installationen, Nachbesserungen, Eingriffen in die Registry und Updates gar nicht mehr richtig nachvollziehen.
Nur soviel: mir fehlte (plötzlich?) das Windows SDK für Visual Studio, ich hab’s also nachinstalliert.
Zuvor habe ich den Registry-Eintrag für das alte Visual Studio 14 (besser bekannt unter Visual Studio 2015) auf die neue Version (Visual Studio 2017) geändert, das war beim Update wohl damals schief gelaufen. Nachdem ich auch die letzten Reste vom alten Visual Studio entfernt und das allerneueste Visual Studio 2019 installiert hatte, mit allen möglichen Komponenten, die ich vielleicht mal gebrauchen könnte – liess sich UE dazu herab, gar nicht mehr zu funktionieren.
Ich also Visual Studio 2015 erneut installiert, inklusiver aller möglicher Komponenten, die man mal gebrauchen könnte. Derzeit habe ich also drei verschiedene Visual Studio Community Versionen auf dem Rechner.
UE verlautbarte, nicht zum ersten Mal, es gebe ein ungültiges Zeichen im BuildTool. Gibt’s gar nicht, aber das brachte mich dazu, das inzwischen neu erschienene UE 4.22.irgendwas zu installieren.
Und dann noch einmal das Quick Start Projekt nachzubilden, um zu sehen, ob denn jetzt endlich alles funktioniert.
Es tat, juchhu. Jetzt habe ich auch wieder eine funktionierende Verknüpfung, um UE nicht immer über den Epic Games Launcher starten zu müssen. Und ich weiss, mit welcher Visual Studio Version ich arbeite, der 2017er nämlich.
Die anderen beiden lasse ich trotzdem drauf, man weiss ja nie.

Abgelegt unter Technikgedöns | Kommentare deaktiviert für Visual Studio und Unreal Engine